An upgrade to our editing tools has been released, significantly improving performance while editing. This update is now live and has resolved the performance issues previously noticeable on larger pages.
Posted Feb 27, 2025 - 15:26 NZDT
Update
We have identified a fix for the issue causing very slow editing controls on larger pages. We aim to have this resolved this afternoon.
Posted Feb 27, 2025 - 14:24 NZDT
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 27, 2025 - 11:24 NZDT
Investigating
We are currently investigating issues where some customers are noticing slow to load websites when editing.
Posted Feb 27, 2025 - 10:03 NZDT
This incident affected: Australia, New Zealand, United Kingdom, and USA.