Design studio login
Incident Report for Rocketspark
Resolved
This incident has been resolved.
Posted Mar 14, 2023 - 12:31 NZDT
Investigating
There are currently issues where users are unable to log into websites from their Design Studio. We are aware of the issue and are currently investigating as a high priority
Posted Mar 14, 2023 - 12:13 NZDT
This incident affected: Design Studio.