Investigating issues with the signup process

Incident Report for Rocketspark

Resolved

The issues with the signup process have been resolved. We apologise for any inconvenience caused.
Posted May 13, 2026 - 00:46 NZST

Identified

We have identified the issue and are working on a fix. We will provide an update once resolved.
Posted May 13, 2026 - 00:43 NZST

Update

We are still investigating issues with the signup process and will provide an update as soon as we have more information.
Posted May 13, 2026 - 00:14 NZST

Investigating

We are currently investigating issues with the signup process, as some customers have reported problems.
Posted May 12, 2026 - 23:54 NZST
This incident affected: Australia, New Zealand, United Kingdom, and USA.