Phones down
Incident Report for Rocketspark
Resolved
This incident has been resolved.
Posted May 19, 2023 - 14:50 NZST
Identified
The issue has been identified and a fix is being implemented.
Posted May 19, 2023 - 11:40 NZST
Investigating
We are currently experiencing issues with receiving and making phone calls. We are actively monitoring our phone system and working on a fix. Please send all support requests to support@rocketspark.com during this time.
Posted May 19, 2023 - 11:40 NZST
This incident affected: Australia, New Zealand, United Kingdom, USA, and Design Studio.