Investigating outage for Rocketspark UK
Incident Report for Rocketspark
Resolved
The incident has now been resolved.
Posted Feb 05, 2024 - 08:22 NZDT
Investigating
Currently investigating an outage in our UK region.
Posted Feb 05, 2024 - 08:12 NZDT
This incident affected: United Kingdom.