Investigating an outage on our UK systems
Incident Report for Rocketspark
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 06:52 NZST
Investigating
We are currently investigating this issue.
Posted Apr 26, 2024 - 06:42 NZST
This incident affected: United Kingdom.